@prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
@prefix owl: <http://www.w3.org/2002/07/owl#> .
@prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
@prefix xml: <http://www.w3.org/XML/1998/namespace> .
@prefix xsd: <http://www.w3.org/2001/XMLSchema#> .

<http://purl.org/spar/mito/MentionType> a owl:Class;
  rdfs:label "mention type"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentionType mito:explicit .

    mito:explicit a mito:MentionType .
    """;
  rdfs:comment "The reified implicit or explicit characteristic of a mention."@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

<http://www.ontologydesignpatterns.org/cp/owl/situation.owl#isSettingFor> a owl:ObjectProperty;
  rdfs:label "is setting for"@en;
  rdfs:comment "The relation between a situation and something that situation is a setting for."@en;
  rdfs:domain <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#Situation>;
  rdfs:isDefinedBy <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#> .

<http://purl.org/spar/mito/hasMentionedEntity> a owl:ObjectProperty;
  rdfs:label "has mentioned entity"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentionedEntity :my-mentioned-entity .
    """;
  rdfs:comment "The relation between a mention and a mentioned entity."@en;
  rdfs:domain <http://purl.org/spar/mito/Mention>;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  rdfs:subPropertyOf <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#isSettingFor>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

<http://purl.org/spar/mito/hasMentionType> a owl:ObjectProperty;
  rdfs:label "has mention type"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentionType mito:explicit .
    """;
  rdfs:comment "The implicit or explicit characterisation of the mention it is describing."@en;
  rdfs:domain <http://purl.org/spar/mito/Mention>;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  rdfs:range <http://purl.org/spar/mito/MentionType>;
  rdfs:subPropertyOf <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#isSettingFor>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

<http://purl.org/spar/mito> a owl:Ontology;
  <http://purl.org/dc/elements/1.1/contributor> "Sebastian Barzaghi (https://orcid.org/0000-0002-0799-1527)",
    "Silvio Peroni (https://orcid.org/0000-0003-0530-4305)";
  <http://purl.org/dc/elements/1.1/creator> "Matteo Guenci (https://orcid.org/0009-0006-3139-1667)";
  <http://purl.org/dc/elements/1.1/date> "2026-08-14";
  <http://purl.org/dc/elements/1.1/description> """
The **_Mention Typing Ontology (MiTO)_** is an OWL 2 DL ontology designed to formalize the concept of mentions, which are crucial for bibliometric analysis, as they allow researchers to track references to entities (e.g., software) in scholarly communication. This ontology aims to enhance interoperability with other SPAR ontologies by providing a flexible framework for describing mentions and their characteristics.

Mentions can be explicit (e.g., directly stated references in text, as when stated into an article \"Dr. Johnson's groundbreaking research on climate change\") or implicit (e.g., indirect references to entities or concepts, such as discussing \"seminal studies in the field\"). 

MiTO introduces the following key concepts:
* **Mention**, which represents the act of referring to or introducing the name of a person, entity, or concept in discourse. 
This class is defined with minimal restrictions to maximize usability across different contexts.
* **MentionType**, which reifies the implicit or explicit nature of a mention, enabling users to classify mentions based on their characteristics.

MiTO also defines several object properties to describe relationships between mentions and entities:
* `mito:mentions` and its inverse `mito:isMentionedBy`, which connect the two sides involved in the act of mentioning.
* `mito:hasMentionedEntity`, which relates a mention to the entity being mentioned.
* `mito:hasMentioningEntity`, which relates a mention to the entity performing the act of mentioning.
* `mito:hasMentionType`, which defines the implicit or explicit character of the mention.

![The architecture of MiTO.](mito.png)

MiTO is designed to integrate with other SPAR ontologies, which provides a modular framework for describing crucial aspects of bibliographic entities and their metadata. 

## Examples of use

In the following subsections, we introduce some examples to showcase how to use MiTO. 

The prefixes that are used in all the examples provided below are defined as follows:

    @prefix : <http://www.sparontologies.net/example/> .
    @prefix mito: <http://purl.org/spar/mito/> .
    @prefix fabio: <http://purl.org/spar/fabio/> .
    @prefix oa: <http://www.w3.org/ns/oa#> .
    @prefix dcterms: <http://purl.org/dc/terms/> .
    @prefix foaf: <http://xmlns.com/foaf/0.1/> .
    @prefix cnt: <http://www.w3.org/2011/content#> .
    @prefix c4o: <http://purl.org/spar/c4o/> .
    @prefix per: <http://data.semanticweb.org/person/> .

### Defining mention links and their types (direct vs reified)

MiTO lets you connect two resources where one (the _mentioning entity_, e.g., a paper) mentions another (the _mentioned entity_, e.g., a software, dataset, method), optionally qualifying the mention with a _mention type_ (e.g., explicit/implicit). 
As with [CiTO](http://purl.org/spar/cito), you can use a direct triple (`mito:mentions`) or a reified mention (`mito:Mention`) to which you can attach further metadata such as the mention type.

    :ml-paper-2024 a fabio:JournalArticle ;
        dcterms:title \"Deep Learning Approaches for Medical Image Segmentation\" ;
        mito:mentions :tensorflow .

    :tensorflow a fabio:ComputerProgram ;
        foaf:name \"TensorFlow\" ;
        mito:isMentionedBy :ml-paper-2024 .

    :mention-tensorflow a mito:Mention ;
        mito:hasMentioningEntity :ml-paper-2024 ;
        mito:hasMentionedEntity :tensorflow ;
        mito:hasMentionType mito:explicit .

    :vision-paper a fabio:JournalArticle ;
        dcterms:title \"Novel Architectures for Biomedical Image Classification\" .

    :imagenet a fabio:Dataset ;
        dcterms:title \"ImageNet Large Scale Visual Recognition Challenge Dataset\" .

    :vision-paper mito:mentions :imagenet .
    
    :dataset-mention a mito:Mention ;
        mito:hasMentioningEntity :vision-paper ;
        mito:hasMentionedEntity :imagenet ;
        mito:hasMentionType mito:explicit .

    :mention-annotation a oa:Annotation ;
        oa:motivatedBy oa:commenting ;
        oa:hasTarget :dataset-mention ;
        oa:hasBody :usage-context .

    :usage-context a cnt:ContentAsText ;
        cnt:chars \"ImageNet is used exclusively for pre-training the backbone network, not for final model evaluation.\" .

    :nlp-paper a fabio:JournalArticle ;
        dcterms:title \"Contextual Embeddings for Scientific Text Classification\" .

    :bert-method a fabio:ResearchPaper ;
        dcterms:title \"Bidirectional Encoder Representations from Transformers\" .

    :bert-mention a mito:Mention ;
        mito:hasMentioningEntity :nlp-paper ;
        mito:hasMentionedEntity :bert-method ;
        mito:hasMentionType mito:explicit .

    :bert-pointer a c4o:InTextReferencePointer ;
        c4o:hasContent \"[BERT]\" .

    :pointer-annotation a oa:Annotation ;
        oa:hasTarget :bert-pointer ;
        oa:hasBody :bert-mention ;
        oa:annotatedBy per:research-team .

    :nlp-paper mito:mentions :bert-method .

    :stats-paper a fabio:JournalArticle ;
        dcterms:title \"Bayesian Approaches to Uncertainty Quantification in Deep Learning\" .

    :bayesian-theory a fabio:ResearchPaper ;
        dcterms:title \"Bayesian Statistical Inference\" .

    :stats-paper mito:mentions :bayesian-theory .

    :implicit-theory-mention a mito:Mention ;
        mito:hasMentioningEntity :stats-paper ;
        mito:hasMentionedEntity :bayesian-theory ;
        mito:hasMentionType mito:implicit .

    :implicit-annotation a oa:Annotation ;
        oa:motivatedBy oa:commenting ;
        oa:hasTarget :implicit-theory-mention ;
        oa:hasBody :implicit-explanation .

    :implicit-explanation a cnt:ContentAsText ;
        cnt:chars \"Bayesian theory is applied throughout the methodology but never explicitly referenced by name.\" .

## Competency Questions

MiTO can be used for answering several questions related to mentions in scholarly resources.
In the following subsections, some of them are introduced together with their respective SPARQL queries. 

The prefixes that are used in all the SPARQL queries provided below are defined as follows:

    PREFIX mito: <http://purl.org/spar/mito/>
    PREFIX dcterms: <http://purl.org/dc/terms/>
    PREFIX foaf: <http://xmlns.com/foaf/0.1/>
    PREFIX oa: <http://www.w3.org/ns/oa#>
    PREFIX cnt: <http://www.w3.org/2011/content#>
    PREFIX c4o: <http://purl.org/spar/c4o/>

### CQ1

Which entities are mentioned by a document, along with their types and titles?

    SELECT ?document ?mentionedEntity ?entityType ?entityName
    WHERE {
        ?document mito:mentions ?mentionedEntity .
        ?mentionedEntity a ?entityType .
        OPTIONAL { ?mentionedEntity dcterms:title ?entityName . }
        OPTIONAL { ?mentionedEntity foaf:name ?entityName . }
    }

### CQ2

What are the mentions, their types, and the entities involved?

    SELECT ?mention ?mentioningEntity ?mentionedEntity ?mentionType
    WHERE {
        ?mention a mito:Mention ;
            mito:hasMentioningEntity ?mentioningEntity ;
            mito:hasMentionedEntity ?mentionedEntity ;
            mito:hasMentionType ?mentionType .
    }

### CQ3

What textual comments or annotations target a specific mention?

    SELECT ?mention ?mentionType ?commentText
    WHERE {
        ?mention a mito:Mention ;
            mito:hasMentionType ?mentionType .
        ?annotation a oa:Annotation ;
            oa:hasTarget ?mention ;
            oa:hasBody ?body .
        ?body cnt:chars ?commentText .
    }

### CQ4

Which in-text reference pointers are linked to a mention via annotations?

    SELECT ?pointer ?pointerContent ?mention ?mentionedEntity ?annotator
    WHERE {
        ?pointer a c4o:InTextReferencePointer ;
            c4o:hasContent ?pointerContent .
        ?annotation a oa:Annotation ;
            oa:hasTarget ?pointer ;
            oa:hasBody ?mention .
        ?mention a mito:Mention ;
            mito:hasMentionedEntity ?mentionedEntity .
        OPTIONAL { ?annotation oa:annotatedBy ?annotator . }
    }
"""@en;
  <http://purl.org/dc/elements/1.1/title> "The Mention Typing Ontology (MiTO)"@en;
  <http://purl.org/dc/terms/bibliographicCitation> "Matteo Guenci. The Mention Typing Ontology. Revision: 1.1.0. http://purl.org/spar/mito.";
  <http://purl.org/dc/terms/created> "2024-05-09";
  <http://purl.org/dc/terms/issued> "2024-05-09";
  <http://purl.org/dc/terms/license> <http://creativecommons.org/licenses/by/4.0/>;
  <http://purl.org/dc/terms/modified> "2026-08-14";
  <http://purl.org/dc/terms/publisher> <https://ror.org/00wb4mk85>;
  <http://purl.org/dc/terms/source> <https://github.com/SPAROntologies/mito/blob/master/docs/cq.md>;
  <http://purl.org/ontology/bibo/doi> "TBA";
  <http://purl.org/ontology/bibo/status> <http://purl.org/ontology/bibo/status/published>;
  <http://purl.org/vocab/vann/changes> """
* **v1.1.0**: 
Added new documentation, including annotation properties (e.g., `bibo:doi`, `schema:codeRepository`, etc.), term properties (e.g., `vann:example`, `vs:term_status`, etc.), exemplary competency questions with their respective SPARQL queries, and a Grafoo diagram.
Added new named individuals `mito:explicit` and `mito:implicit` (previously only mentioned in documentation as `mito:ExplicitMention` and `mito:ImplicitMention`).
Specified that `mito:Mention` is a subclass of `sit:Situation` and, as a consequence, its properties as subproperties of `sit:isSettingFor`.
    """@en;
  <http://purl.org/vocab/vann/preferredNamespacePrefix> "mito"@en;
  <http://purl.org/vocab/vann/preferredNamespaceUri> "http://purl.org/spar/mito"@en;
  rdfs:seeAlso <http://www.sparontologies.net/ontologies/mito>;
  owl:backwardCompatibleWith <http://purl.org/spar/mito/2024-05-09>;
  owl:imports <http://www.ontologydesignpatterns.org/cp/owl/situation.owl>;
  owl:priorVersion <http://purl.org/spar/mito/2024-05-09>;
  owl:versionIRI <http://purl.org/spar/mito/2026-08-14>;
  owl:versionInfo "1.1.0";
  <http://xmlns.com/foaf/0.1/logo> <https://github.com/SPAROntologies/mito/blob/master/spar.png>;
  <https://schema.org/codeRepository> <https://github.com/SPAROntologies/mito>;
  <https://schema.org/image> <https://github.com/SPAROntologies/mito/blob/master/docs/current/mito.png>;
  <https://schema.org/includedInDataCatalog> <https://fairsharing.org/>;
  <https://schema.org/keywords> "bibliometrics"@en, "scholarly mentions"@en, "scholarly publishing"@en,
    "scientometrics"@en, "semantic publishing"@en .

<http://purl.org/spar/mito/isMentionedBy> a owl:ObjectProperty;
  rdfs:label "is mentioned by"@en;
  <http://purl.org/vocab/vann/example> """
    :my-software a fabio:Software ;
        dcterms:title \"Tensorflow\" ;
        mito:isMentionedBy :my-journal-article .
    """;
  rdfs:comment "The relation between the two sides involved in the act of mentioning, with one entity being mentioned by the other."@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  owl:inverseOf <http://purl.org/spar/mito/mentions>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

<http://purl.org/spar/mito/implicit> a <http://purl.org/spar/mito/MentionType>, owl:NamedIndividual;
  rdfs:label "implicit"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentioningEntity :my-mentioning-entity ;
        mito:hasMentionedEntity :my-mentioned-entity ;
        mito:hasMentionType mito:implicit .
    """;
  rdfs:comment """
A type of mention according to which something is suggested or understood through context rather than named directly within a text.
    """@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-072889B72F6B66F5F6BBCE67F022B0DD a owl:Restriction;
  owl:cardinality "1"^^xsd:nonNegativeInteger;
  owl:onProperty <http://purl.org/spar/mito/hasMentionType> .

<http://purl.org/spar/mito/mentions> a owl:ObjectProperty;
  rdfs:label "mentions"@en;
  <http://purl.org/vocab/vann/example> """
	:my-journal-article a fabio:JournalArticle ;
        dcterms:title \"Deep Learning Approaches for Medical Image Segmentation\" ;
        mito:mentions :my-software .
    """;
  rdfs:comment "The relation between the two sides involved in the act of mentioning, with one entity mentioning the other."@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

<http://purl.org/dc/elements/1.1/contributor> a owl:AnnotationProperty .

<http://www.ontologydesignpatterns.org/cp/owl/situation.owl#Situation> a owl:Class;
  rdfs:label "situation"@en;
  rdfs:comment "A view on a set of entities. It can be seen as a 'relational context', reifying a relation."@en;
  rdfs:isDefinedBy <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#> .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-E97931594D9B5A3BFFA49EEE7EA70477 rdf:first
    _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-ABE5AA69FAB58E1AE39D51B8D896BA63;
  rdf:rest rdf:nil .

<http://purl.org/dc/elements/1.1/description> a owl:AnnotationProperty .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-51C56D796F30399802463B99E8EC7A33 rdf:first
    _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-C7B40DED8988701A0BAE8E3B9546A9A5;
  rdf:rest _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-E97931594D9B5A3BFFA49EEE7EA70477 .

<http://purl.org/spar/mito/hasMentioningEntity> a owl:ObjectProperty;
  rdfs:label "has mentioning entity"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentioningEntity :my-mentioning-entity .
    """;
  rdfs:comment "The relation between a mention and a mentioning entity."@en;
  rdfs:domain <http://purl.org/spar/mito/Mention>;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  rdfs:subPropertyOf <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#isSettingFor>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-ABE5AA69FAB58E1AE39D51B8D896BA63 a owl:Restriction;
  owl:cardinality "1"^^xsd:nonNegativeInteger;
  owl:onProperty <http://purl.org/spar/mito/hasMentioningEntity> .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-607B047C5B8E301B61465EB2066DB768 rdf:first
    <http://www.ontologydesignpatterns.org/cp/owl/situation.owl#Situation>;
  rdf:rest _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-9C09410121B1EEF2015C7CD7C5136E39 .

<http://purl.org/spar/mito/Mention> a owl:Class;
  rdfs:label "mention"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentioningEntity :my-mentioning-entity ;
        mito:hasMentionedEntity :my-mentioned-entity ;
        mito:hasMentionType mito:explicit .
    """;
  rdfs:comment """
The action or an act of referring to, remarking upon, or introducing the name of a person or thing in spoken or written discourse, often incidentally and as not necessarily essential to the discussion.
"""@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  rdfs:seeAlso <https://www.oed.com/dictionary/mention_n?tl=true/>;
  owl:equivalentClass _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-0B43E05CC4398AB1417EB9AF345A67D7;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable>;
  <http://www.w3.org/2004/02/skos/core#note> """
Originally: the action of calling to mind or commemorating something in speech or writing.
    """@en .

<http://purl.org/dc/elements/1.1/rights> a owl:AnnotationProperty .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-C7B40DED8988701A0BAE8E3B9546A9A5 a owl:Restriction;
  owl:cardinality "1"^^xsd:nonNegativeInteger;
  owl:onProperty <http://purl.org/spar/mito/hasMentionedEntity> .

<http://purl.org/dc/elements/1.1/creator> a owl:AnnotationProperty .

<http://purl.org/spar/mito/explicit> a <http://purl.org/spar/mito/MentionType>, owl:NamedIndividual;
  rdfs:label "explicit"@en;
  <http://purl.org/vocab/vann/example> """
    :my-mention a mito:Mention ;
        mito:hasMentioningEntity :my-mentioning-entity ;
        mito:hasMentionedEntity :my-mentioned-entity ;
        mito:hasMentionType mito:explicit .
    """;
  rdfs:comment """
A type of mention according to which there is a direct, unambiguous, and literal naming or stating of something within a text.
    """@en;
  rdfs:isDefinedBy <http://purl.org/spar/mito/>;
  <http://www.w3.org/2003/06/sw-vocab-status/ns#term_status> <http://purl.org/linked-data/registry#statusStable> .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-0B43E05CC4398AB1417EB9AF345A67D7 a owl:Class;
  owl:intersectionOf _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-607B047C5B8E301B61465EB2066DB768 .

_:genid-32bcfa2bb3d54030a1e0e8b5464777361642-9C09410121B1EEF2015C7CD7C5136E39 rdf:first
    _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-072889B72F6B66F5F6BBCE67F022B0DD;
  rdf:rest _:genid-32bcfa2bb3d54030a1e0e8b5464777361642-51C56D796F30399802463B99E8EC7A33 .

<http://purl.org/dc/elements/1.1/title> a owl:AnnotationProperty .

<http://purl.org/dc/elements/1.1/date> a owl:AnnotationProperty .
